13

I'm new on this community. I tried to leave a comment a few minutes ago on the page "section numbering in 'tufte-book'", but i accidentally post an "answer".

The given MWE uses tufte-book. I suspect that tufte-book uses the package titlesec. The most recent version of titlesec, which is a week old, causes the same error.

On "Formatting subsections and chapters in tufte-book" is stated "...The tufte documentclass loads the titlesec package..."

So this makes me believe that titlesec is the cause of the problem, even if this package isn't visible in the shown MWE.

I wasn't able to rectify my post, because it was deleted. I now have to have 50 point, but i don't know how to get them.

Kind regards,

Richard

migrated from tex.stackexchange.com Mar 29 '16 at 17:24

This question came from our site for users of TeX, LaTeX, ConTeXt, and related typesetting systems.

  • 5
    I doubt posting a new question is the right way either, but I will give you a +1 for earnest effort. Welcome to the site. – Steven B. Segletes Mar 29 '16 at 16:31
  • here's a response in a comment that appeared with what you posted: " It's true that titlesec had a small bug, but this was fixed, but the O.P. is not using titlesec according to the MWE, so this is not related." so really, a new question is in order, which is this one. tufte-book does not use titlesec, so for that to be relevant, it would have to be included with usepackage. – barbara beeton Mar 29 '16 at 16:35
  • I thougth I was sending a message to Christian Hupfer, because I clicked on his name. But apparently it become some kind of post. – user101863 Mar 29 '16 at 16:37
  • I am willing to check with the older version of titlesec before it was updated some days ago. – user31729 Mar 29 '16 at 16:38
  • I'm using Miktex and Texmaker. I would like to know how to install an older version of titlesec, because the latest version gives me problems. That's what led me to this site. – user101863 Mar 29 '16 at 16:41
  • Oh my, the newer titlesecversion from 2016/03/21 is working, apparently there was an intermediate version with some bug that was published some days earlier (2016/03/16) has the bug and the section numbers are vanishing in the document body (but not in the ToC) – user31729 Mar 29 '16 at 16:45
  • @Richard: I am sorry, it was a fault to delete your answer, you're right, most likely! I've voted to undelete your answer – user31729 Mar 29 '16 at 16:45
  • Ok, no problem. But i'm still curious, how do you download and install a version of a package, which is not the latest version? – user101863 Mar 29 '16 at 16:51
  • @Richard -- i have to retract my earlier comment that tufte-book doesn't use titlesec. it doesn't load it directly, but one of the subsidiary packages it calls does load it. – barbara beeton Mar 29 '16 at 16:52
  • @Richard: I'm using TeXLive and by default, during updates, there's a backup of the old package version. I've just placed the contents of the old version in a local directory and compiled the example from the other question. The version is from 2016/03/15 -- that's the buggy one (whatever the bug is, right now), the one from 2016/21/03 is working fine – user31729 Mar 29 '16 at 16:53
  • Ow, isee. I have version 2.10.1 installed (2.10.2 is the latest version). So i have most probably the faulty version of 2016/03/15. – user101863 Mar 29 '16 at 17:01
  • Maybe George, the guy which posted the question at "tex.stackexchange.com/questions/301362/…" also has version 2.10.1 installed. Which gives him the same problem. – user101863 Mar 29 '16 at 17:02
  • Because Barbara confirmed that tufte-book uses titlesec – user101863 Mar 29 '16 at 17:05
  • @Richard Note that she's barbara in this case, not Barbara ;-) – yo' Mar 30 '16 at 18:40

You must log in to answer this question.