1

My reputation history clearly says, that I have 'earned' (well ;-)) at least 200 reputation on 9 days (see the data at the end of this post, please)

However, there is a mismatch with my reputation graph chart (count the spikes: there are 10 spikes ;-))

enter image description here

Is there any apparent reason for this?

My reputation history for the last days.

 2    237679 (10)
 2    237679 (10)
 2    237792 (10)
 2    237776 (10)
 2    237792 (10)
-- 2015-04-09 rep +165  = 22592     

** rep today: 165
** rep this week (2015-04-05 - 2015-04-11): 567
** rep this month (2015-04-01 - 2015-04-30): 567
** rep this quarter (2015-04-01 - 2015-06-30): 567
** rep this year (2015-01-01 - 2015-12-31): 6074
** rep from bonuses: 100
** total rep 22592 :)

days represented 398
rep cap was reached via rep from upvotes *only* on 4 days
earned at least 200 reputation on 9 days
earned 122 reputation from suggested edits

The full reputation history is available here reputation history

Edit

Werner identified the cause...

enter image description here

  • 1
    That's weird... :) I can reproduce the graph (from your user profile), but I can't reproduce the "reputation history" you receive from doing a reputation recalc. Could you post that information somewhere? Perhaps on PasteBin? There's no personal information contained in there AFAIK... – Werner Apr 9 '15 at 23:44
  • @Werner: Thanks for your efforts! See my edit. Hope the PasteBin stuff works, never used it so far ;-) – user31729 Apr 9 '15 at 23:57
  • The strangeness can be localized to March 28-29. The graph shows reputation of 210|110 (=320) yet your reputation history shows 185|135 (=320)... – Werner Apr 10 '15 at 0:33
  • @Werner: Let me have a look into the detailed votes there – user31729 Apr 10 '15 at 0:36
  • You'll see that they match the graph. So something weird is going on with the reputation recalc. What you will also note is that your reputation recalc and graphs are out by one day... strange. – Werner Apr 10 '15 at 0:37
  • @Werner: I added the voting history to the post... There was an unaccept/unupvote by the OP on 30th March, while accepted/upvoted on 29th March. And again the accepting/upvoting by the OP on 30th March. Damn... I did not notice this – user31729 Apr 10 '15 at 0:42
  • @Werner: I think, I should delete my question – user31729 Apr 10 '15 at 9:05
  • I don't... I've asked about this bizarreness on the Tavern on Meta Stack Exchange. Give it a little time first. – Werner Apr 10 '15 at 14:45
  • @Werner: alright. Basically it's like the restoring of reputation after serial downvoting etc, in my opinion, but it didn't work here in this case. Thanks again for your efforts – user31729 Apr 10 '15 at 15:41
2

The problem can be isolated to the following dates: March 28 & 29, 2015.

Your reputation graph shows:

enter image description here

This shows reputation gain of

  • +210 for March 28, 2015
  • +110 for March 29, 2015

However, your reputation history shows:

-- 2015-03-28           = 21695     
 2    235611 (10)
 2    235611 (10)
 1    235611 (15)
 2    235611 (10)
 2    235702 (10)
 2    235702 (10)
 2    235702 (10)
 2    235617 (10)
 2    235702 (10)
 2    235611 (10)
 2    235702 (10)
 2    235702 (10)
 2    235707 (10)
 2    235741 (10)
 2    235741 (10)
 2    235741 (10)
 2    235779 (10)
 2    235779 (10)
              rep +185  = 21880     
-- 2015-03-29
 2    235779 (10)
 2    235702 (10)
 1    235702 (15)
 2    235882 (10)
 2    235882 (10)
 2    235882 (10)
 2    234019 (10)
 2    234019 (10)
 2    206919 (10)
 2    234019 (10)
 2    235882 (10)
 2    235882 (10)
 2    235882 (10)
              rep +135  = 22015 

This shows reputation gain of

  • +185 for March 28, 2015
  • +135 for March 29, 2015

The differences account for the missing "at least 200 reputation on a day" count. Here's what happened:

enter image description here

An accepted answer on one day was unaccepted and re-accepted on another.

Another bug stems from the fact that your graph display doesn't match the other reputation timelines. The graph and reputation recalc points to the problem happening on March 28/29, while your timeline reputation view points to March 29/30.

  • This are real bugs then? – user31729 Apr 11 '15 at 6:54
  • @ChristianHupfer: In my opinion, yes. However, I don't know why. And it's difficult to reproduce it in general for other users. Well, I don't know if it exists for other users as well. – Werner Apr 11 '15 at 13:34
  • Thanks for your inquiries... Perhaps others report a similar behaviour as well – user31729 Apr 11 '15 at 15:08

You must log in to answer this question.