6

in the list for Which questions led to the creation of a new package?, the listing for tqft contains a reference to a "Blog: The TQFT Package", which in turn contains an additional (and apparently unexpected) url.

the blog reference is useful information. unfortunately, the urls cited for every package listed after this one are messed up, with only the actual url appearing; the question titles are absent unless they happen to be included in the "long form" of the applicable url. it's my guess that the formatting routine is expecting only the "unprotected" url for the package as listed following "Origin:".

a couple of entries down, there's also an "extra" url in the entry for xpatch. a previous edit (47) attempted (unsuccessfully) to "clean up" the question titles and url formatting for xpatch and the following entry; even on the edit page the formatting is corrupted. looking at the progression of edits, the corruption apparently didn't occur immediately on the addition of tqft, but with the addition of a couple of new entries above that.

this is such a useful and (generally) well formatted list that it's a shame to see the formatting "fall apart" at the end.

screen shot by Speravir:

Screenshot image

  • A quick test edit suggests to me that the problem is not the link itself but the total size of the post. If you remove the blog link, nothing alters in the preview. If you remove the tqft entry entirely, the next link is correct then things go wrong again! Needs fixing at the 'back end', but we may need to split the list anyway at some point, which I think would also fix things. – Joseph Wright Nov 3 '12 at 14:22
  • I’ve added a screenshot. I’ve made it, because I misunderstood you first, therefore also the mousepointer with the tooltip (Firefox 16.0.2). – Speravir Nov 3 '12 at 16:07
  • @Speravir -- thanks for screen shot. helps with making sense without actually having to go to the referenced question. (someday i'll learn to make screenshots. promise.) – barbara beeton Nov 3 '12 at 16:22
  • No problem (and oh, it’s „screen shot” …). – Speravir Nov 3 '12 at 16:36
  • @JosephWright One way or the other, it seems to be a bug in the system, doesn't it? – doncherry Nov 5 '12 at 8:09
  • @doncherry Yes, no question about that: I just wanted to narrow down what the nature of the bug is. Hopefully the devs will pick this up (they do check all of the metas for bugs). – Joseph Wright Nov 5 '12 at 8:54
4

This is fixed now.

We had placed an arbitrary limit on the number of links that would be automatically rewritten with their full question titles (40, on meta sites).

This limit was apparently too low, so we bumped it up to a much higher (still arbitrary) number. Hopefully you won't run into it again any time soon.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .