5

When I read Andrey Vihrov's comment on the question XeLaTeX and Microtype, I noticed that the tooltips of the links to other questions produced by the title HTML attribute are all the same, even though they refer to different questions. There seems to be a bug in the handling of automatically cropped tex.sx links.

enter image description here (The title of the question that I was pointing at [underlined] actually is How to get hanging hyphenation?)

The corresponding source code confirms this behavior; strangely, for every question the title attributes and values of the preceding <a> tags are added and it seems browsers just take the first attribute and ignore the others.

enter image description here

(Behavior confirmed for FF5.0, Safari 5.0.5, IE 9.0.8112.16421, all on Win7 64bit. Still, no matter what browsers do, the redundant and wrong attributes should be eliminated.)

  • Also, the title-tooltips are all lowercase and ignore any punctuation. I'm guessing this is hard to avoid because the mechanism takes the titles from the URLs, which show the same characteristics for good reasons. Nonetheless, in the long run a different solution would be nice, the tooltips would improve in readability and a general policy of proper capitalization and punctuation in question titles would be fostered. – doncherry Jul 2 '11 at 19:51
5

Oops – nice catch, thanks.

Fixed in the code, so it will behave correctly after the next build.

  • 1
    BTW: Could we also get auto-formatting of post links to the post title like inside other posts? (I know that's a thing for meta.sx) – Martin Scharrer Jul 3 '11 at 19:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .